S7-200 CPU 226 硬件版本太低

在软件中显示版太低不能用Modbus rtu 库,请问如何解决?

最佳答案

1、Modbus RTU 主站库对CPU的版本有要求。CPU 的版本必须为 2.00 或者 2.01(即订货号为 6ES721*-***23-0BA*),1.22版本之前(包括1.22版本)的 S7-200 CPU 不支持。如图
见下面的链接。
http://www.ad.siemens.com.cn/productportal/Prods/s7-200-portal/MicroPower2013/s7-200/communication/modbus/modbus%20master/Modbus%20master.htm
S7-200 不支持CPU固件更新,详见《S7-200 CPU 的固件更新》
https://support.industry.siemens.com/cs/document/17634731
2、
在编程时,按图所示,要么在线读一下CPU的固件,若CPU实际版本高而编程时使用的版本低,那读到新版本后,兴许可以呢。

图片说明:

S7-200 CPU 226 硬件版本太低  

提问者对于答案的评价:
可以

原创文章,作者:ximenziask,如若转载,请注明出处:https://www.zhaoplc.com/plc371647.html

发表评论

登录后才能评论